rails4.2.0和spree3.0和dotenv-rails冲突的问题

Ruby | 2015-04-08 14:06:59 | 阅读 2448 次 | 评论(0)

默认安装的dotenv-rails的版本是2.0.1,运行时出现错误:

/Users/gs/.rvm/gems/ruby-2.2.1@rails420/gems/railties-4.2.0/lib/rails/railtie/configuration.rb:95:in `method_missing': undefined method `eager_load_paths' for #<Rails::Railtie::Configuration:0x007fb329e66660> (NoMethodError)

from /Users/gs/.rvm/gems/ruby-2.2.1@rails420/gems/deface-1.0.1/lib/deface/railtie.rb:50:in `block (2 levels) in <class:Railtie>'

。。。。。。。。。。。。。。


把dotenv-rails 换成 1.0.2 版本,问题解决。

这里有讨论:https://github.com/bkeepers/dotenv/issues/177

文章评论,共0条
游客请输入验证码
浏览1921144次
文章归档
最新评论
  • Miss_Zou:不都是复制粘贴的吗
  • Miss_Zou:目测是大佬
  • 神犇dengyuhy:语文很好