hdu1071 The area

作者在 2011-08-12 16:42:53 发布以下内容
Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 
#include<stdio.h>
#include<math.h>
int main()
{
    int t;
    double a1,b1,a2,b2,a3,b3,area;
    double s1,s2,l,h,a,k,b,x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&a1,&b1,&a2,&b2,&a3,&b3);
        h=a1;l=b1;
        a=(b2-b1)/((a2-a1)*(a2-a1));
        k=(b3-b2)/(a3-a2);
        b=b2-k*a2;
        x=a3;
        s1=(a*x*x*x/3)-(a*h+k/2)*x*x+(a*h*h+l-b)*x;
        x=a2;
        s2=(a*x*x*x/3)-(a*h+k/2)*x*x+(a*h*h+l-b)*x;
        printf("%.2lf\n",s1-s2);
    }
    return 0;
}
 
ACM编程 | 阅读 753 次
文章评论,共0条
游客请输入验证码
浏览753次
文章归档
最新评论