#include<stdio.h>
/*题目内容:
班级第一次列队,通常老师会让同学按身高排成一列,然后1、2报数,喊到1的同学向前一 步,就这样,队伍就变成两列了。假设现在一个班级有n个同学,并且他们已经按身高排成 了一列,同学按身高从1到n编号,你能告诉我最后哪些编号的同学站在了第一列么?
输入格式:
输入一个正整数n,表示班级的人数。
输出格式:
按顺序输出所有在第一列的同学对应的编号,每两个编号之间用一个空格隔开,最后一个编号后面没有空格。
输入样例
11
输出样例1 3 5 7 9 11*/
//转换为求1-n之间的所有奇数模型
int main(i...
#include <stdio.h>
//UTC是世界协调时,BJT是北京时间,UTC时间相当于BJT减去8。
//输入样例:803 输出样例:3
int main(){
int time_0,time_1;
int BJT_time(int);
void UTC_time(int);
//printf("请按样例输入时间(如803)\n");BJT
scanf("%d",&time_0);
if(time_0<=2359 && time_0>=0){
time_1=BJT_t...
#include<stdio.h>
#include<math.h>
/*实现功能给出一个不多于5位的整数,要求 :
1、求出它是几位数 2、分别输出每一位数字(数字间留空格)
3、按逆序输出各位数字,例如原数为321,应输出123*/
int main(int argc,char*argv[])
{
int Num;//数字存放变量
int k;//数字个数
int fun1(int), fun2(int,int);//声明功能函数
scanf("%d",&Num);
k=fun1(Num);
f...
void 蛇形矩阵(bool 正 = true)
{//缘由https://bbs.bccn.net/viewthread.php?tid=499489&page=1&extra=#pid2720322
int n, x, y;
cin >> n;
x = y = n / 2;
int a[50][50]{{ 0 }};
int num = 1, 上左 = x - 1, 下右 = x + 1, 向 = 1;
a[x][y] = num;
while (num<n*n)
{
if (向)
{
if (正...
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Threading.Tasks;/*命名空间提供简化编写并发和异步代码的工作的类型。*/
using System.Windows.Forms;
using System.IO;
...
int[] shuzu = new int[111];
string xinm = "";//缘由https://ask.csdn.net/questions/1056757
Console.Write("输入人员数量:");
int lian = int.Parse(Console.ReadLine()), j = 0;
while (lian > j)
{
Console.Write("输入姓名:");
...
#include<stdio.h>
//四个数比较大小(冒泡排序由小到大)
/*核心思想:变量寄存,两两比较*/
int main(int argc,char *argv[]){
int a,b,c,d,num;
scanf("%d%d%d%d",&a,&b,&c,&d);
if(a>b){num=a;a=b;b=num;}
if(a>c){num=a;a=c;c=num;}
if(a>d){num=a;a=d;d=num;}
if(b>c){num=b;b=c;...
分段多位数乘法4千乘以4千与4千乘以8位的原则是一样的,从左到右相乘,最高位相乘后,往后位的进位与前位相加。不想再设计了,这里只做描述和一个8位相乘的代码例子记录,估计的虽说堪舆傅里叶变换快速乘法媲美,还是觉得稍逊一点。同样的道理可用加法、减法、除法,其重点就是对进位用加法进行处理,而一次可以处理多位,受数据类型位数的限制,只能取其位数的一半-1位作为乘法,加法、减法、除法则可达18位推理的位数。
从低位往高位算也是一样的原则,(有一点区别就是要让进位暂存,等运算完成后再用加法计算进位。)从程序写作来说,从高位往低位进行运算写程序比较方便。
说白了就是传统的算法把多位数当作1位...
#include <stdio.h>
//字符串拼接算法
int main(int argc,char *argv[])
{
char a[20],b[20];
void fun(char *,char *);//函数声明
printf("请输入两个字符串\n");
scanf("%s %s",a,b);
fun(a,b);
printf("%s\n",a);
return 0;
}
void fun(char x[],char y[])
{
int i=0,k=0;
while...
#include<stdio.h>
/*编写一个程序,输入a、b、c三个值,输出其中最大值。*/
int main()
{
int a,b,c,result=0;
int comp(int,int,int);
scanf("%d %d %d",&a,&b,&c);
result=comp(a,b,c);
printf("%d\n",result);
return 0;
}
int comp(int x,int y,int z)
{
int i;
i=x>y?x:y;//...
#include <stdio.h>
/*有一头母牛,它每年年初生一头小母牛。每头小母牛从第四个年头开始,每年年初也生一头小母牛。请编程实现在第n年的时候,共有多少头母牛?*/
int main() {
int n,count;
int path(int);
scanf("%d",&n);
count=path(n);
printf("%d\n",count);
return 0;
}
int path(int n)
{
if (n<4)
return 2;
else return path(n-1)+path(...
void 水仙十全十美()
{
long long 数 = 153, 和 = 0, 幕 = 数, 借 = 数, 方 = 1;
while (数 <= 18000000000000000000)
{ //缘由https://bbs.bccn.net/thread-499381-1-1.html
if (幕)
方 *= 借 % 10, 幕 /= 10;
else if (借)
幕 = 数, 和 += 方, 方 = 1, 借 /= 10;
else if (和 == 数)
cout << 和 << ends, ...
int aaa = 0, aaaa = 0, a = 111, aa = a, jc = a; string zc = "";
while (a < 999)
{ //缘由https://bbs.bccn.net/thread-499358-1-1.html
if (aa)aaa = aa % 10, aaaa += aaa*aaa*aaa, aa /= 10;
else
if (jc == aaaa || zc.find(to_string(aaaa)) != string::npos)
cout << a << "固定=>" << j...
Sub 狐狸找兔子(ByVal 数组() As Integer, Optional ByVal 找位 As Integer = 0, Optional ByVal 序位 As Integer = 1)
Dim 选 = ""
Do
找位 = 找位 Mod 10
Console.WriteLine(数组(找位))
Console.WriteLine(序位.ToString("间隔0"))
If 选.Contains(数组(找位)...
Sub 递归逆向(ByVal 数 As Integer)
Console.Write(数 Mod 10)
数 = 数 - (数 Mod 10)
数 = 数 / 10
If 数 > 0 Then
递归逆向(数)
Else
Console.WriteLine()
End If
End Sub
int aa = 111, aaa = 0, aaaa = 0, a = aa;
while (a < 999)
{ //缘由https://bbs.bccn.net/viewthread.php?tid=499370&pid=2719622&page=1#pid2719622
if (aa)aaa = aa % 10, aaaa += aaa*aaa*aaa, aa /= 10;
else
if (a == aaaa)cout << a << ends, aa = ++a, aaaa = 0; else aa = ++a, ...
Sub Main()
继续:
Dim 测时 As New Diagnostics.Stopwatch
测时.Start()
'===============================================================================================================
Dim 数 = 1000000000000000000
While 数 <= 1000000000000010000
...
void 合成位数并求质数()
{//缘由https://bbs.bccn.net/viewthread.php?tid=499357&pid=2719481&page=1#pid2719481
int shu[100]{0}, xu = 0, ge = 0, wei = 0, he = 0, mu = 1, j = 0;
cin >> ge >> wei;
while (xu<ge)cin >> shu[xu++]; xu = wei;
while (j<ge - 2)if (xu)he += shu[--xu + j] * mu, m...
缘由https://bbs.bccn.net/redirect.php?tid=499353&goto=lastpost#lastpost
直接写未调试
int 数=12340,合=0,计=0;
计=数;
while(计)合=合*10+计%10,计/=10;
cout<<数+合;
缘由https://bbs.bccn.net/redirect.php?tid=499354&goto=lastpost#lastpost
直接写未调试
int 个=0,小=110,大=0,均=0,数=0;
while(1)
{
cin>>数;
if(数==-1)break;
++个;
if(数>大)大=数;
if(数<小)小=数;
均+=数;
}
cout<<小<<"小"<<大<<"大均"<<均/个;