杭电OJ1015题,测试样例能过,但提交为wrong answer,求指导

作者在 2019-02-23 15:50:33 发布以下内容

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1015

代码不知错在哪里了,求指导

题目:


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input



1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END


 

Sample Output
		
	
	
LKEBA YOXUZ GHOST no solution


代码部分:

#include<stdio.h>
#include<string.h>
#include<math.h>
#define EPSILON 0.1
int main()
{
    double num1;
    int flag,v,w,x,y,z,len;
    char a[20]= {0};
    double b[20]= {0};
    for(int i=0; i<20; i++)
    {
        a[i]=0;
    }
    while(scanf("%lf %s",&num1,a)!=EOF)
    {
        if(num1==0&&strcmp(a,"END")==0)
        {
            break;
        }
        flag=0;
        //把字符型数据组转换成数字型
        for(int i=0; i<20; i++)
        {
            b[i]=a[i];


        }
        len=strlen(a);
        for(int j=0; j<len; j++)
        {
            b[j]=b[j]-64;


        }
        for(v=len-1; v>=0; v--)
        {
            for(w=len-1; w>=0; w--)
            {


                for(x=len-1; x>=0; x--)
                {


                    for(y=len-1; y>=0; y--)
                    {


                        for(z=len-1; z>=0; z--)
                        {
                            if(w!=v&&x!=v&&x!=w&&y!=v&&y!=w&&y!=x&&z!=v&&z!=w&&z!=x&&z!=y)
                            {
                                if(fabs(num1-(b[v]-pow(b[w],2)+pow(b[x],3)-pow(b[y],4)+pow(b[z],5)))<EPSILON)
                                {
                                    printf("%c%c%c%c%c\r\n",a[v],a[w],a[x],a[y],a[z]);
                                    flag=1;
                                    v=w=x=y=z=-1;
                                }




                            }
                        }
                    }
                }
            }
        }


        if(flag==0)
        {
            printf("no solution\r\n");
        }


    }


    return 0;


}



默认分类 | 阅读 1814 次
文章评论,共0条
游客请输入验证码
文章分类
文章归档
最新评论