作者在 2011-03-23 23:11:52 发布以下内容
用指针实现字符统计
时限:1000ms 内存限制:10000K 总时限:3000ms
描述:
是用指针编程:输入一行文字,统计其中大写字母、小写字母、空格以及数字字符的个数。
输入:
一行字符。
输出:
大写字母、小写字母、空格以及数字字符的个数,每个数字占一行。
输入样例:
GGatT 123
输出样例:
3
2
1
3
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
int main()
{
char a[100];
char *p;
int upper,lower,blank,num;
upper=lower=blank=num=0;
p=a;
gets(a);
while(*p!='\0')
{
if(isupper(*p))
upper++;
else if(islower(*p))
lower++;
else if(*p==' ')
blank++;
else if(isdigit(*p))
num++;
p++;
}
printf("%d\n%d\n%d\n%d\n",upper,lower,blank,num);
return 0;
}
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
int main()
{
char a[100];
char *p;
int upper,lower,blank,num;
upper=lower=blank=num=0;
p=a;
gets(a);
while(*p!='\0')
{
if(isupper(*p))
upper++;
else if(islower(*p))
lower++;
else if(*p==' ')
blank++;
else if(isdigit(*p))
num++;
p++;
}
printf("%d\n%d\n%d\n%d\n",upper,lower,blank,num);
return 0;
}