数字排序

作者在 2011-03-22 23:43:10 发布以下内容
数字排序 时限:1000ms 内存限制:10000K  总时限:3000ms

描述:

给你N个数字,请用冒泡法对这N个数字进行降序排序,并输出结果

输入:

第一行为N,N<=20 ;
第二行为N个数字,这N个数字用一个空格隔开
所有数均可用int型表示

输出:

把这些数字用降序输出,每行输出一个,最后输出一个回车

输入样例:

8
23 12 36 98 54 76 21 58

输出样例:

98
76
58
54
36
23
21
12

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
int main()
{
  int  a,b,temp,j;
  int  c[25];
  int  *p;
  p=c;
  scanf("%d",&a);
  for(b=0;b<a;b++)
  {
      scanf("%d",&c[b]);
  }
  for(b=0;b<a-1;b++)
  {
      p=&c[b];//p每次都要指向头
      for(j=b;j<a;j++)
      {
          if(c[j]>*p)
          {
              p=&c[j];
          }
      }
      temp=c[b];
      c[b]=*p;
      *p=temp;
  }
  for(b=0;b<a;b++)
  {
      printf("%d\n",c[b]);
  }
  return 0;
}
默认分类 | 阅读 992 次
文章评论,共9条
xdzsm
2011-03-23 16:50
1
<img src="image/face/1.gif" class="face">好
尤慕思
2011-03-24 11:55
2
不错<img src="image/face/2.gif" class="face">
变幻小子
2011-03-24 19:09
3
你好&nbsp;&nbsp;路过看看
维海(作者)
2011-03-26 19:40
4
<img src="http://ftphi.bccn.net/002/201103/26/511045_1301139642u4b2.jpg">
维海(作者)
2011-03-26 19:41
5
<div class="quote"><span class="q"><b>尤慕思</b>: 不错<img src="image/face/2.gif" class="face"></span></div>呵呵,谢谢夸奖哦
维海(作者)
2011-03-26 19:45
6
没看清题目,没用冒泡
紫凤双飞
2011-03-27 00:50
7
你怎么知道你的程序使用的内存不超过10000K呢?如何才能看出呢
潜修僧
2011-04-10 13:59
8
#include&lt;iostream&gt;<br />
using namespace std;<br />
int main()<br />
{int N;//需要冒泡排序数的个数。<br />
cin&gt;&gt;N;<br />
int a[100];<br />
for(int i=0;i&lt;N;i++)<br />
cin&gt;&gt;a<i>;//输入需要排序的数<br />
for(int i=0;i&lt;N-1;i++)<br />
&nbsp; &nbsp; &nbsp; &nbsp; for(int j=0;j&lt;N-i-1;j++)<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; if(a[j]&lt;a[j+1])<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; {int temp=a[j];<br />
&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp; a[j]=a[j+1];<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp;&nbsp;a[j+1]=temp;<br />
&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp;}<br />
//冒泡排序算法<br />
for(int i=0;i&lt;N;i++)<br />
cout&lt;&lt;a<i>&lt;&lt;endl;//输出排序后的数<br />
return 0;<br />
}
维海(作者)
2011-04-20 22:51
9
<div class="quote"><span class="q"><b>紫凤双飞</b>: 你怎么知道你的程序使用的内存不超过10000K呢?如何才能看出呢</span></div>这个要经过专门系统检验
游客请输入验证码
浏览69263次