作者在 2012-04-01 14:40:53 发布以下内容
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011
样例输出
3
0
3 、
#include <stdio.h>
#include <string.h>
int main()
{
int n;
char str1[1002],str2[1002];
scanf("%d%*c",&n);
while(n--) 输入有多少组数据
{
gets(str1);
gets(str2);
int len1=strlen(str1),len2=strlen(str2),i,j;
int num=0,k;
for(i=0;i<=len2-len1;++i) //从开头进行比较
{
int flag=1; //表示相不相等的一种状态
for(j=i,k=0;k<len1;j++,k++) //j和k齐头并进
if(str2[j]!=str1[k])
{
flag=0;
break;
}
if(flag)
num++; //计数有多少相等的
}
printf("%d\n",num);
}
return 0;
}
水题一个,纯属娱乐。。。。。。。。。
#include <string.h>
int main()
{
int n;
char str1[1002],str2[1002];
scanf("%d%*c",&n);
while(n--) 输入有多少组数据
{
gets(str1);
gets(str2);
int len1=strlen(str1),len2=strlen(str2),i,j;
int num=0,k;
for(i=0;i<=len2-len1;++i) //从开头进行比较
{
int flag=1; //表示相不相等的一种状态
for(j=i,k=0;k<len1;j++,k++) //j和k齐头并进
if(str2[j]!=str1[k])
{
flag=0;
break;
}
if(flag)
num++; //计数有多少相等的
}
printf("%d\n",num);
}
return 0;
}