队列问题

作者在 2012-03-28 08:25:41 发布以下内容
Train Problem I
时间限制:3000 ms  |  内存限制:65535 KB
难度:1
描述As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
输入The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.输出The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
样例输入3 123 321 3 123 312 样例输出Yes. in in in out out out FINISH No. FINISH

#include <stdio.h>
#include <string.h>
int main()
{
    int n;
    while(scanf("%d%*c",&n)!=EOF)
    {
        char in[100],out[100],stay[100],co[1000];
        int len_in=0,len_out=0,ok=0,len_stay=0;
        scanf("%s%s",in,out);
        strcpy(co,"Yes.\n");  
        while(1)
        {
            if(len_stay==0&&len_in<n)  //当车站停站台为空的时候,火车进入停站台
            {
                stay[len_stay++]=in[len_in++];
                strcat(co,"in\n");  //进站时把进站顺序记一下。
                continue;
            }
            if(out[len_out]==stay[len_stay-1])    //当停站台最外边的火车与相应的的开走的火车号一样时,停站台的火车开走
            {
                len_stay--;
                len_out++;
                strcat(co,"out\n"); //把出站顺序记一下
                continue;
            }
            if(len_in<n)  //当以上两种情况都不符时,继续向停站台开进火车。
            {
                stay[len_stay++]=in[len_in++];
                strcat(co,"in\n");
                continue;
            }
            if(len_out<n)  //执行这个条件,表明出去的火车没有和进站顺序对上号,表明出站顺序有误
                ok=1;
            break;
        }
        if(ok)
            printf("No.\nFINISH\n");
        else
            printf("%sFINISH\n",co);
    }
    return 0;
}        
 
默认分类 | 阅读 873 次
文章评论,共0条
游客请输入验证码
文章分类
最新评论