最大长方形

作者在 2012-03-20 22:28:53 发布以下内容
描述
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100. Then follow n integers h1, ..., hn, where 0 <= hi <= 100000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.样例输入7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0样例输出8 4000
#include <stdio.h>
int main()
{
    int i,n,a[101];
    while(scanf("%d",&n),n!=0)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        int max=0,min=100000;
        for(i=0;i<n;i++)   //用i来控制出现多少长方形
            for(int j=0;j<=i;j++)  //用j来遍历出现长方形的所有情况
            {
                for(int k=j;k<=i;k++)  //用k来查找所有长方形中最小的高
                {
                    if(a[k]<min)
                        min=a[k];
                }
                if(max<(i-j+1)*min)
                    max=(i-j+1)*min;
                min=100000;
            }
        printf("%d\n",max);
    }
    return 0;
}
枚举法
 
默认分类 | 阅读 1234 次
文章评论,共0条
游客请输入验证码
文章分类
最新评论