作者在 2012-03-11 15:49:47 发布以下内容
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 输入 The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. 输出 Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order. 样例输入 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT 样例输出 CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA 这是一个关于逆序数的题,按照逆序数从小到大的形式输出: 下面是我的ac码
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 输入 The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. 输出 Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order. 样例输入 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT 样例输出 CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA 这是一个关于逆序数的题,按照逆序数从小到大的形式输出: 下面是我的ac码
#include <stdio.h>
#include <string.h>
#define STDNA struct dna
STDNA
{
char a[51];
int t;
};
int main()
{
int n,m,i,j;
STDNA p[100],mi;
scanf("%d%d%*c",&m,&n);
for(i=0;i<n;i++) //输入多少字符串
{
int k,co=0;
gets(p[i].a);
for(j=0;j<m;j++) //统计每个字符串逆序数
{
for(k=j;k<m;k++)
if(p[i].a[j]>p[i].a[k])
co++;
}
p[i].t=co;
}
printf("\n");
for(int flag=1,i=0;i<n&&flag;i++) //字符串逆序数按按从小到大排序
for(flag=0,j=0;j<n-i-1;j++)
if(p[j].t>p[j+1].t)
{
mi=p[j];
p[j]=p[j+1];
p[j+1]=mi;
flag=1;
}
for(i=0;i<n;i++) //输出字符串,按逆序数从小到大输出
printf("%s\n",p[i].a);
return 0;
}
#include <string.h>
#define STDNA struct dna
STDNA
{
char a[51];
int t;
};
int main()
{
int n,m,i,j;
STDNA p[100],mi;
scanf("%d%d%*c",&m,&n);
for(i=0;i<n;i++) //输入多少字符串
{
int k,co=0;
gets(p[i].a);
for(j=0;j<m;j++) //统计每个字符串逆序数
{
for(k=j;k<m;k++)
if(p[i].a[j]>p[i].a[k])
co++;
}
p[i].t=co;
}
printf("\n");
for(int flag=1,i=0;i<n&&flag;i++) //字符串逆序数按按从小到大排序
for(flag=0,j=0;j<n-i-1;j++)
if(p[j].t>p[j+1].t)
{
mi=p[j];
p[j]=p[j+1];
p[j+1]=mi;
flag=1;
}
for(i=0;i<n;i++) //输出字符串,按逆序数从小到大输出
printf("%s\n",p[i].a);
return 0;
}