rails命令出现大量 warning: constant ::Fixnum is deprecated 的解决办法

Ruby | 2019-01-21 00:21:57 | 阅读 157 次 | 评论(0)

这些警告虽然不影响使用,但看着烦人。按以下方法可解决:

which rails 找到rails的路径(我的是 /Users/gs/.rvm/gems/ruby-2.5.3/bin/rails,当然你的和我的可能会不一样),然后:

vim /Users/gs/.rvm/gems/ruby-2.5.3/bin/rails

在第一行和注释下面加上:

ENV['RUBYOPT'] = '-W0'

这样就可以屏蔽warning了

QQ20190121-0.png (上传于2019-01-21 00:23:16)
QQ20190121-0.png

-------------------------------- 作者在 2019-01-21 04:00:44 补充以下内容 --------------------------------

刚刚试了试,上述方法只有在rails项目的目录中才管用,在其它目录不管用,不过大部分rails命令都是在rails项目中使用,比如: 

rails db:migrate rails g 

migration xxxxxx 

所以这篇博客对大部分情况管用,当然更完美的方法是升级rails

文章评论,共0条
游客请输入验证码
浏览1760765次
文章归档
最新评论
  • 静夜思:过奖了
  • Furau:很少有速度这么快,界面清爽的免费博客啦,赞一个,希望永远安在。